Author Topic: Component stopped working?  (Read 2329 times)

Offline Bebrona

  • Coccinella
  • *
  • Posts: 22
  • Karma: +0/-0
Component stopped working?
« on: 18 October 2015, 14:59:13 »
When i click on the Abook component i get the message " Component not found" but it is installed and inside the component menu

How can i fix this?

In frontpage the component works, in backend i can't add books

Please help.

I CAN SEND DONATION WHEN THIS IS FIXED!

Offline federica

  • Amministratore
  • Delfino
  • *****
  • Posts: 1.043
  • Karma: +1/-0
Re: Component stopped working?
« Reply #1 on: 20 October 2015, 13:16:29 »
It seems the folder administrator/components/com_abook has problems.
Download the installation package then install again Abook without uninstall it.
Al mondo ci sono 10 tipi di persone, quelli che hanno capito il codice binario e quelli che non l'hanno capito.
http://www.antivirushelp.it
stacca la spina!

Offline Bebrona

  • Coccinella
  • *
  • Posts: 22
  • Karma: +0/-0
Re: Component stopped working?
« Reply #2 on: 21 October 2015, 19:57:32 »
Frederica

When i install the component again (without uninstall) i get this error.  And the problem isn't fixed.

What should i do next?

Duplicate entry '1' for key 'PRIMARY' SQL=INSERT INTO `b9pwl_abcategories` (`id`, `asset_id`, `parent_id`, `lft`, `rgt`, `level`, `path`, `extension`, `title`, `alias`, `note`, `description`, `published`, `checked_out`, `checked_out_time`, `access`, `params`, `metadesc`, `metakey`, `metadata`, `created_user_id`, `created_time`, `modified_user_id`, `modified_time`, `hits`, `language`) VALUES (1, 0, 0, 0, 1, 0, '', 'system', 'ROOT', 'root', '', '', 1, 0, '0000-00-00 00:00:00', 1, '{}', '', '', '', 0, '2009-10-18 16:07:09', 0, '0000-00-00 00:00:00', 0, '*');

Offline federica

  • Amministratore
  • Delfino
  • *****
  • Posts: 1.043
  • Karma: +1/-0
Re: Component stopped working?
« Reply #3 on: 25 October 2015, 15:15:44 »
Strange, if you install abook without uninstall it, the installer doesn't install the database tables because the tables already exist
Al mondo ci sono 10 tipi di persone, quelli che hanno capito il codice binario e quelli che non l'hanno capito.
http://www.antivirushelp.it
stacca la spina!

Offline Bebrona

  • Coccinella
  • *
  • Posts: 22
  • Karma: +0/-0
Re: Component stopped working?
« Reply #4 on: 25 October 2015, 15:39:34 »
So how can i solve this? I send donation after fix!

Offline Bebrona

  • Coccinella
  • *
  • Posts: 22
  • Karma: +0/-0
Re: Component stopped working? SOLVED
« Reply #5 on: 28 October 2015, 13:51:30 »
I solved the problem MYSELF    ;D

Workarround.

- backup database
- export abcategories to SQL
- delete abcategories
- install component
- delete abcategories
- import abcategories from SQL

SOLVED

Strange component was not working anymore SUDDENLY


Offline federica

  • Amministratore
  • Delfino
  • *****
  • Posts: 1.043
  • Karma: +1/-0
Re: Component stopped working?
« Reply #6 on: 15 November 2015, 19:06:56 »
Hi Bebrona,
thank you for your feedback
Al mondo ci sono 10 tipi di persone, quelli che hanno capito il codice binario e quelli che non l'hanno capito.
http://www.antivirushelp.it
stacca la spina!