Author Topic: Component stopped working  (Read 2817 times)

Offline Bebrona

  • Coccinella
  • *
  • Posts: 22
  • Karma: +0/-0
Re: Component stopped working
« Reply #7 on: 13 August 2015, 19:39:13 »
I can't do the test because i can't create new category and reorder it.

Offline Bebrona

  • Coccinella
  • *
  • Posts: 22
  • Karma: +0/-0
Re: Component stopped working
« Reply #8 on: 13 August 2015, 19:45:13 »
The Back-end of the administratorpart to add Categories looks different for my website than for the testwebsite you provide.



Offline federica

  • Amministratore
  • Delfino
  • *****
  • Posts: 1.043
  • Karma: +1/-0
Re: Component stopped working
« Reply #9 on: 14 August 2015, 09:37:24 »
Are you using abook 3.1.0 in joomla 3.4.3? If no I suggest to update them both.
Al mondo ci sono 10 tipi di persone, quelli che hanno capito il codice binario e quelli che non l'hanno capito.
http://www.antivirushelp.it
stacca la spina!

Offline Bebrona

  • Coccinella
  • *
  • Posts: 22
  • Karma: +0/-0
Re: Component stopped working
« Reply #10 on: 15 August 2015, 09:57:27 »
I use abook 3.1.0 and joomla 3.4.3

Today i noticed my component was gone in backend.  So i tried to reinstall it. Then i got this error

Duplicate entry '1' for key 'PRIMARY' SQL=INSERT INTO `b9pwl_abcategories` (`id`, `asset_id`, `parent_id`, `lft`, `rgt`, `level`, `path`, `extension`, `title`, `alias`, `note`, `description`, `published`, `checked_out`, `checked_out_time`, `access`, `params`, `metadesc`, `metakey`, `metadata`, `created_user_id`, `created_time`, `modified_user_id`, `modified_time`, `hits`, `language`) VALUES (1, 0, 0, 0, 1, 0, '', 'system', 'ROOT', 'root', '', '', 1, 0, '0000-00-00 00:00:00', 1, '{}', '', '', '', 0, '2009-10-18 16:07:09', 0, '0000-00-00 00:00:00', 0, '*');

Offline Bebrona

  • Coccinella
  • *
  • Posts: 22
  • Karma: +0/-0
Re: Component stopped working
« Reply #11 on: 15 August 2015, 10:02:58 »
A few days agoo the component worked, today i get this error when i click on an item in the menubar

See attachement photo

Offline federica

  • Amministratore
  • Delfino
  • *****
  • Posts: 1.043
  • Karma: +1/-0
Re: Component stopped working
« Reply #12 on: 24 August 2015, 10:40:42 »
Hi Bebrona,
I suggest to uninstall com_abook, delete all database tables related to abook and reinstall it. I inform you in advance that all books data will be deleted.

Database tables related tu abook:
`#__abauthor`,
`#__abbook`,
`#__abbookauth`,
`#__abbooktag`,
`#__abcategories`,
`#__abeditor`,
`#__ablocations`,
`#__ablibrary`,
`#__abrating`,
`#__abtag`,
`#__abtag_groups`,
`#__ablend`;
Al mondo ci sono 10 tipi di persone, quelli che hanno capito il codice binario e quelli che non l'hanno capito.
http://www.antivirushelp.it
stacca la spina!