Recent Posts

Pages: [1] 2 3 ... 10
Supporto (Support) / Re: Russian alphabet pagination
« Last post by teko on Yesterday at 11:17:16 »
Thank you very much.
Supporto (Support) / Re: Modification of Lending Request Form
« Last post by adaniel on 19 May 2018, 01:55:17 »
After refreshing my files list, I did find the default.php file, mentioned at the link above.  That was a problem on my end with the file not displaying.

I am now wondering

1) What would it take to add a feature so that when a lending request is submitted, an email is sent to a designated recipient?  In our case this would be our librarian.

2) we need to collect more fields of data for those making a lending request.  This would include the company name and mailing address for us to ship the requested item to the user.

Would you have time to do the above work, for a fee ?  If so, how would we arrange that ?

Thank you -

Supporto (Support) / Modification of Lending Request Form
« Last post by adaniel on 15 May 2018, 20:51:55 »
How can I modify the Lending Request Form ?  I need to add some additional fields to collect information that will be submitted to our library in the lending request email.

I found a topic addressing this here:
"Currently abook doesn't provides the possibility to manage the forms by backend area. You must modify the form by php code.
You can find the request form in this file components/com_abook/views/book/tmpl/default.php"

However, the location for the link given in the above does not contain a file named default.php. 

Thanks -

Errori (Bugs) / Re: error in category
« Last post by federica on 15 May 2018, 12:41:06 »
Hi alizayni,
try to delete and create again the related menu item.
Supporto (Support) / Re: Russian alphabet pagination
« Last post by federica on 15 May 2018, 12:39:01 »
Try to change following files:
components/com_abook/models/category.php line 316
Code: [Select]
$letter      =$jinput->get('letter', '', 'WORD');to
Code: [Select]
$letter      =$jinput->get('letter', '', 'STRING');
components/com_abook/helpers/icon.php line 169
Code: [Select]
$selected=$jinput->get('letter', '', 'WORD');to
Code: [Select]
$selected=$jinput->get('letter', '', 'STRING');
components/com_abook/models/authors.php line 110
Code: [Select]
$letter      =$jinput->get('letter', '', 'WORD');to
Code: [Select]
$letter      =$jinput->get('letter', '', 'STRING');
Errori (Bugs) / error in category
« Last post by alizayni on 15 May 2018, 11:39:20 »
when i go and click on category (1945) in this page
i get this error

error: 1054

Unknown column 'use_book' in 'order clause' SQL=SELECT CONCAT(a.lastname, " ", AS author, AS idauthor, a.alias FROM #__abbookauth AS b INNER JOIN #__abauthor AS a ON = b.idauth WHERE b.idbook = 1 ORDER BY use_book

please advice
Supporto (Support) / Re: Russian alphabet pagination
« Last post by teko on 12 May 2018, 06:21:05 »
Пушкин, Толстой, Некрасов
Thanks for the tips.  The menu problem is now solved.  I looked in the #_extensions table and did find an entry for abook that had the "use_book" in the params field.  I did not change anything there, but at your suggestion, I edited the menu item that was not working.  Under "Book Options" tab, and the field "Author Order", there was a "Use Book" setting.  I changed it to "Ascending".  The menu now works correctly.

For future reference when working with ABook, can you explain to me why my having a "Use Book" setting in "Author Order" was causing the error I previously mentioned ?  Is it due to some field within one of the tables containing imported data that was either empty, or filled with invalid information ?  The reason I ask is that we may want to use the "Use Book" setting of the "Author Order" field at some point in the future, and I would like to be able to resolve the underlying problem, if at all possible.

Here is something else I observed:

After the import, I edited 22 of the library items through the ABook extension to fix things such as titles, descriptions, etc.  Once I had applied the fix to the "All Items" menu item (as described above), at first the only library items that would be displayed were the 22 library items that I had edited in ABook from the backend.  The other 328 items were not showing up when the menu was clicked.  All 348 items were showing up on the backend, but only 22 showed up when I clicked the menu on the front end.  After looking into the MySQL table and comparing field contents between the 22 that did display with those that did not display, I noticed the ones that displayed all had a number in "asset_id".  The ones that did not display had nothing in that field.  I experimented by going to the back end and editing one of the books that did not have an asset_id.  I made no changes to field content, instead I just clicked "Save".  That book was then assigned an asset_id by ABook, and it now shows up on the front end when I clicked on the "All Items" menu item.  I tried this on another dozen books, and the same thing happened.  The asset_id would be created and the library items would appear when clicking on the "All Books" menu item.  Obviously, there were some internal linkings/connections that were not created yet, and by bringing up the item, then clicking "Save", ABook is creating those links automatically.
Is there a way to recreate those internal links without bringing each library item individually and clicking "Save"?  If not, fortunately, we do only have 348 items in our library, and we can edit each one -- and then click "Save" -- if we need to.

Again, thank you for your assistance, and the tips in getting the menu problem resolved.

Ah ok, I understud.
The "use_book" string may be present in both #_menu or #_extensions tables, not in abook tables.

Have you try to change the option "Use book settings" to "default" in every selectbox you see (abook menu configuration and abook general configuration)?

Otherwise try to delete the menu item and create it again or try to change author order (in general configuration or menu configuration).
Thank you for the information.  I realize that I was not clear in my first post about the data import.  I did not migrate my data from an older version of ABook.  We had never used ABook before, so the installation of ABook under Joomla was a completely new installation on a site where ABook had never been installed before. New install of Joomla, and new install of the latest version of ABook.  The data that I migrated was from a different library software.  I formatted that data into separate CSV files, each matching the structure of the tables I indicated in my previous post, and imported the data through CSV.  That is why I was confused about the "missing column".  The version of ABook that I downloaded and installed from your site was version 3.1.4 from the "downloads" link.  It is listed as the current version of ABook.

From your response, it seems that somehow in the import process I either left a field empty that should have content, or placed content into a field that should be empty.   What table and field is this error about "use_book" column actually referring to ?  I can perhaps modify my table/fields contents through MySQL to eliminate the error.

Thank you for your help -


Pages: [1] 2 3 ... 10