Component not in Administrator list

Started by richardh9935, 15 July 2022, 06:16:43

Previous topic - Next topic
A financial contribution is greatly appreciated as a support, to help us to keep live the project.
If you like this project you can donate some piece of BitCoin to this address: bc1qy5tgq6tvrckac2a57unxvqcnxamrvhduve9sj9

richardh9935

Dear Team,
Abook is working very well in our Joomla4 website (cactusact.org.au)

In the Administrator interface, under the Components tab, all the other components I've installed appear. However, Abook does not appear. I can see it clearly under "Manage Extensions" and "Update Sites", and it is working.

What could this problem be?
1. a Joomla fault?
2. a fault in my own installation?
3. Something else, to do with Abook?

A financial contribution is greatly appreciated as a support, to help us to keep live the project.
If you like this project you can donate some piece of BitCoin to this address: bc1qy5tgq6tvrckac2a57unxvqcnxamrvhduve9sj9

richardh9935

Dear Team,
I searched the Joomla forum and found comments from others about a similar wide-spread fault between Joomla 3.6.4 and 3.7.3, leading to components not being listed in the Administrator view.

Here is the best link: https://forum.joomla.org/viewtopic.php?f=710&t=953083#p3485284 This should open the forum at a comment by Sozzled.

federica

Hi richardh9935,
thanks for the details.
Did you solve the problem?
Al mondo ci sono 10 tipi di persone, quelli che hanno capito il codice binario e quelli che non l'hanno capito.
[url=http://www.antivirushelp.it]http://www.antivirushelp.it[/url]
[url=http://www.disconnessi.org]stacca la spina![/url]

richardh9935

Federica, it's not resolved yet, partly because I can work around it by typing in the complete URL. It seems to be something to do with the component's entry in the Administrator's Menu.

I will post when I fix it.

A financial contribution is greatly appreciated as a support, to help us to keep live the project.
If you like this project you can donate some piece of BitCoin to this address: bc1qy5tgq6tvrckac2a57unxvqcnxamrvhduve9sj9

federica

Try to check if there are some alerts on system->database
Al mondo ci sono 10 tipi di persone, quelli che hanno capito il codice binario e quelli che non l'hanno capito.
[url=http://www.antivirushelp.it]http://www.antivirushelp.it[/url]
[url=http://www.disconnessi.org]stacca la spina![/url]

richardh9935

Federica, it's solved. I fixed it with some help from Toivo of the Joomla Forum. He suggested re-installing Abook over the top of the existing installation. I tried that, but I received an error message: "The alias com_abook is already being used by the com_abook menu item in the MZone menu."

In a similar forum case, Sozzled suggested using phpMyAdmin to look at the _menu table, to see if there were anomalies. I could not find any, so I thought of changing the com_abook row in the _menu table. I changed every occurrence of "com_abook" in that row of the _menu table so that it was "com_abookx". Then I re-installed Abook over the top of the existing installation.

It did not throw any error messages, and corrected the problem. The Administrator menu item for Abook now shows correctly. All Administrator parts and Site parts seem correct, and all data seems correct.

Thank you for your patience, and thank you for developing Alexandria Book Library.

 :)